软件小子:其实wordpress并非版本越高越好,我之前是个版本控,一有升级提示,就立刻点击升级了,一些核心的插件,比如Akismet,我一直保持最新的,因为垃圾评论总在升级,拦截垃圾的工具也必须与时俱进,后来,我升级到了wordpress4.5.2最新的版本后,发现有不少问题,比如wordpress总是提示内存不足,一直修改,修改了一次之后,好了。后来,又出现了问题,又修改了,于是,改不好了,这是在之前的wordpress4.0版本一直没有出现的问题,反而在最新的版本上一直在重复,搞的我很是被动,网站一度无法打开,而我也不可能老是查看网站是否正常,也就导致了很多访问软件小子的朋友也很被动。

于是,我降级了wordpress,还是用我一直用的wordpress4,.0版本,稳定不会出问题。而我这个人吧,有强迫症,看到更新,就想点,没有还好,于是,搜索教程,去除/关闭/隐藏wordpress版本升级的提示,测试了好几个方法,一度导致网站又出现打不开,乱码的情况,下面的这个方法让我解决了问题,如果你有此问题,可以尝试,但是不保证这个方法适合所有的版本,起码wordpress4.0版本是没有问题的。

方法如下,将如下代码复制并粘贴到 functions.php 这个文本中,我的建议是在此文本的空白处,腾出一块大地方粘贴进去,方便以后想要升级的时候,删除该代码,毕竟到时候你可能会忘记该代码的意思了。还有,就是根据自己的需求来选择下面的代码

禁止,插件更新,主题更新,wordpress本身更新提示的方法

禁止wp更新

add_filter(‘pre_site_transient_update_core’,    create_function(‘$a’, “return null;”)); // 关闭核心提示

add_filter(‘pre_site_transient_update_plugins’, create_function(‘$a’, “return null;”)); // 关闭插件提示

add_filter(‘pre_site_transient_update_themes’,  create_function(‘$a’, “return null;”)); // 关闭主题提示

remove_action(‘admin_init’, ‘_maybe_update_core’);    // 禁止 WordPress 检查更新

remove_action(‘admin_init’, ‘_maybe_update_plugins’); // 禁止 WordPress 更新插件

remove_action(‘admin_init’, ‘_maybe_update_themes’);  // 禁止 WordPress 更新主题


      版权声明:本站提的序列号、注册码、注册机、破解补丁等均来自互联网,仅供学习交流之用,请在下载后24小时内删除。

分类: 办公软件

写下你的见解